维基百科:可视化编辑器/用户指南

维基百科,自由的百科全书
跳转至: 导航搜索
快捷方式
WP:VE/UG
如果您想尝试可视化编辑器而不编辑条目,这儿有个页面可以让你随便做。不用账户就可以使用。

在维基百科,您可以通过新的可视化编辑器界面编辑,或者使用经典的wiki标记(wikitext)标记。可视化编辑器可以在您已登录的情况下和原始的wikitext编辑器并列使用,通过修改您的设置。(因为未注册的编者无法指定参数设置,他们目前无法直接启用可视化编辑器。)启用后,您可以通过点击页面顶部和章节标题上的编辑使用可视化编辑器;同样,您还可以通过点击编辑源代码使用wikitext编辑界面。

可视化编辑器可以在下列类型的页面(命名空间)中使用:

  • 条目(主)
  • 用户
  • 分类
  • 帮助
  • 文件(文件或维基共享资源中的其他页面除外)

本指南包含了一步步的描述,包括了截图、能用可视化编辑器完成的编辑。注意可视化编辑器仍在开发中(也就是“Beta”),因此存在一些已知的局限和bug。例如,许多情况下,尤其是大型的页面,您会发现可视化编辑器会比wikitext编辑要慢。在可视化编辑器仍在开发中之时,您需要复查您的更改以保证编辑完成时没有不想要的修订。

请注意这份指南在新功能发布时会暂时过期。同样,请报告您所遇到的任何问题,并在反馈页发表对可视化编辑器的反馈和建议。



打开可视化编辑器[编辑]


用可视化编辑器编辑时,点击页面顶端的“编辑”标签。几秒钟后就可以打开编辑器编辑,如果页面很长就会用更长的时间。

如果点击“编辑源代码”标签,页面将以传统的wikitext代码编辑器编辑,而不是可视化编辑器。

VisualEditor - Edit tab - 2.png

您还可以点击任意章节标题右边的“编辑”来启动可视化编辑器。编辑时就会跳到那一章,然而整页内容仍可以编辑。

如果您只想编辑一段,最好是从章节标题点击,而不是页顶的标签。因为点击章节链接会自动在编辑摘要中留下那一节的题目(就像下面保存更改一节所描述的)。如果编辑摘要中有章节标题,就会向其他人指示您从条目(页面)的哪里修改的。

Section editing VE Sep2013.png


入门:可视化编辑器工具栏[编辑]


可视化编辑器工具栏
可视化编辑器工具栏会在您开始使用可视化编辑器的时候显示在屏幕顶部。包括了一些图标:

VisualEditor - Toolbar - Undo-redo.png
撤销和恢复您的更改。(如果您没有做撤销和恢复操作,其中一个或两个箭头会是灰的。)

VisualEditor - Toolbar - Headers.png
段落下拉菜单会让您更改文本的标题级别。标准的章节标题是“标题”级别,如图所示。(wiki中称作“二级标题”)

为更改已有标题的级别,您可用此菜单创建一个标题(选中一段文字,再设定级别)以及转换已有标题为标准文本(点击任意一项标题,再点击“段落”)。


VisualEditor - Toolbar - Formatting.png
格式:点击A打开菜单。
  • “粗体”图标(B)加粗所选文本。
  • “倾体”图标(I)倾斜所选文本。
  • “下标”图标(S2)会使所选文字变得更小并置于上方。
  • “上标”图标(S2)会使所选文字变得更小并置于下方。
  • “删除线”图标(S)给所选文字中间加一条横线。
  • “计算机代码”图标({})会给所选文字使用等宽字体(部分浏览器可能无法显示),以使其区别于周围的文字。
  • “下划线”图标(U)给所选文字下面加一条横线。
  • 最后一个图标(“清除样式”,∅)会清除您所选文字的格式。

VisualEditor - Toolbar - Linking.png
链接工具:这个链子是链接工具

VisualEditor - Toolbar - Lists and indentation.png
列表和缩进:前两个图标能让您标号或作项目并列。后两个让您更改所选内容缩进的等级。

VisualEditor insert menu 01 January 2014.png
插入:可视化编辑器上面的“插入”下拉菜单可以进行额外操作,包括添加参考资料或转置模板。
  • “媒体”图标(一座山的图片)打开媒体对话框
  • “参考资料列表”图标(书签)打开编辑参考资料的对话框。
  • “模板”图标(拼图版)让您编辑模板
  • “特殊字符”图标(Ω)让您插入一些特殊符号。(见下文)

VisualEditor - Toolbar - SpecialCharacters.png
插入特殊符号:“特殊符号”图标让您打开一个带有一些能插入文本中的特殊符号的小框。包括一些标准符号、变音和数学符号。

VisualEditor - More Settings.png
更多设置下拉菜单在能让您取消或保存更改的按钮的右边。在更多设置的下边是以编辑分类和使用“语言”图标(拉丁字母A和日文平假名あ)列出语言列表链接来调整页面设置的选项。在一些浏览器中,您可以在可视化编辑器和经典wikitext代码编辑器之间做个切换。

取消或保存您的更改。如果您点击“取消”,您就会看到对话框询问。如果您点击“保存”,您会看到带有带有最后步骤的对话框以完成您的编辑。“保存页面”不能在没有更改的时候编辑。


保存更改[编辑]


当您完成编辑的时候点击工具栏上面绿色的“保存编辑”按钮。
VisualEditor - More Settings.png

现在您会见到一个小框。在此您应该输入所做行为的摘要(标有灰字“描述您的更改”的输入框);这就是编辑摘要

您可以点击输入常用编辑摘要的选项以在输入框中插入短句。

您还可以将您的编辑标为小更改,还可以把您所编辑的页面加入您的监视列表

如果您点击了“检查您的更改”按钮(推荐),您会看到维基百科显示差异的页面。这里采用wikitext格式显示的您编辑前后的版本差异(如果您没有再做更多改动)。

在“检查您的更改”页面,如果您觉得修改的不错,应点击“返回保存表格”以继续保存操作。

最后,在您输入编辑摘要之后、标记小修改及加入监视列表(或者没有),以及检查更改之后,您要点击“保存页面”以完成您的编辑。

New VE save dialog.jpg


编辑链接[编辑]


VisualEditor - Toolbar - Linking.png
想添加連結的話,可以按一下工具列裡的“链接”按鈕(鎖鏈),或者使用快捷鍵Ctrl+K(Mac上面是 Command+K)。

先選取一段文字或者把游標放在字詞當中的話,按一下“链接”按鈕會把連結添加到該段文字上。如果您需要为文本设定格式,确保在这之前做了调整,而且只有在之后才能加链接。


VisualEditor - Link editing inline 2.png
不论用图标还是快捷方式,都会弹出指定链接的对话框。

对于内部链接(维基百科称作wikilink),只要动手您想要链接的页面即可。随着您的输入,可视化编辑器会通过尝试寻找相似的目标来帮助。其实选择内部链接需要两步:

  • 确认:确保可视化编辑器的对勾标在您想要的链接的左边。反之,您可以继续输入直到以选中,或者——如果您输入完成,或者不想再输入——您可以点击您想要的链接以移动对勾。如果您想要的链接不存在(维基百科称作“紅字連結”),对勾会在搜索不到任何您所要的对象的情况下保持在适当位置。 Enter以确认,此时,对话框不会显示任何搜索结果,就是您的选择。
  • 完成:要关闭对话框,您可以键入 Enter,在对话框外点击,或点击完成。
注意:如果您创建了页面指定章节的内部链接,用wikitext输入(#章节名),可视化编辑器会显示红色的目标。您应不必在意。当您输入章节名称,按上文所说:按 Enter确认,再关闭对话框。
如果链接标签和目标不一样,您创建的就是维基百科中的管道链接。

如果您想要插入外部链接,输入(或粘贴)完整域名(http:// .....),再按 Enter确认,再关闭对话框。

对话框一关闭,编辑页面的链接会显示成蓝色(页面不存在时为红色)。就像您在可视化编辑器里的其他更改一样,在保存页面之前不会生效。


VisualEditor - Link editing inline.png
要修改或移除现有的链接,点击文本当中的链接,然后按下在它附近出现的「链接」按钮。您也可以点击工具栏上同样的按钮或者按下键盘上的Ctrl+K快捷键。这三个选项的任何一个会在对话框中启动。

您可以編輯連結的目標,或點選「移除」對話框右上角的圖標(垃圾桶)以完全刪除它。


编辑图像和其他媒体文件[编辑]

添加新的圖像(或其它媒體文件)至頁面中,点選“插入”工具列中的「媒体文件」圖標。圖像将添加到光标所在位置,所以确保光标不要在句子或列表中。
VisualEditor insert menu 01 January 2014.png

点選“媒体文件”圖標,打開一個對話框,可自動搜索維基百科和維基共享資源中與你正在編輯的頁面有關的媒體文件。

你可以查看其他媒體文件,通過更改對話框裏的搜索框的文本。

點擊縮圖以選擇檔案。

VE insert media 7.13.png

一旦插入,該圖像被選擇時(以藍色顯示),你可以在其邊角調整它,將其拖放到所需的位置。
VisualEditor - Media editing 3.png

添加説明,點選圖片上出現的“媒体文件”圖標,對話框會讓您添加(或修改)圖片介紹。媒體對話框允許您添加或編輯媒體介紹,它可以包含格式與連結

當你完成後,點擊“应用更改”關閉對話框並返回到頁面編輯器。

VisualEditor - Media editing 6.png

替换图片或媒体文件,点击以选择(以藍色顯示),再在插入菜单点击媒体图标。您就可以图片或文件替换。
注意:如果您想保留标题,您要在替换前复制标题;这样您就可以在替换以后粘贴到原来的地方并可以补充。)

删除图片或媒体文件,选中并按delete或者← Backspace

编辑参考资料[编辑]

添加新参考资料[编辑]


VisualEditor references more.png
To add a new reference, put the insertion marker at the place in the text where you want to add that new reference. Then click on the "Reference" icon (bookmark) in the "Insert" pulldown toolbar.

VisualEditor reference tool.png
When you click on the "Reference" icon, it will open a submenu with many options similar to those in the toolbar.

VisualEditor reference toolbar transclusion.png
When adding a new reference, many editors create the content using a template, such as "Cite web" or "Cite journal", rather than typing text directly. If you want to use a template, click the Transclusion icon (puzzle piece) in the "more" pulldown of the toolbar of the reference dialog box.

VisualEditor - Editing references 9.png
Then, look for the template you want to use, add it, and edit it as you would an existing template. (For more details on doing this, see the Editing templates section, below.)

Click on "Apply changes" to return to the main reference dialog, and then "Apply changes" again to return to the main editing page.


VisualEditor - Editing references 20.png
In the reference dialog box, you can add, edit, and format your citation directly. You can include a web address (URL).

In the "Options" section, you can make the reference belong to a specific group. This is done, for example, when an article has separate sections for notes and for citations. Most articles only have one group of footnotes, which appear in a section called "References". If you are editing that kind of article, the "Use this group" field should be left blank.

After you've finished creating a reference, click "Apply changes" (bottom right corner of the dialog box) to return to the main editing page.


VisualEditor - Editing references 10.png
If you have just added the first reference(s) to a page, you need to do three things in order for the text of your reference(s) to be properly displayed.

First, at the bottom of the page (if it is an article), just above the "Further reading" section, if there is one, or, if not, just above the "External links" section, you need to create a new section, called "References". Type that word (without quotation marks), select (highlight) it, then use the "Change format" pulldown menu (see above) to make that word into a heading.

Second, place the cursor below this new section heading. Then, in the "Insert" pulldown menu, click the "References list" icon (three books).


VisualEditor - Editing references 11.png
Third, in the references list dialog box, click "Apply changes" to specify that this is where you want the list (text) of references to appear.

As mentioned above, the "Options" section (and, specifically, the "Use this group" box) is used only if there are two or more types of footnotes. If there are, and you're creating a new section for something other than basic footnotes/references, you'll use this box. (For example, you might type "Notes" into the box.) But normally there is only one group of footnotes, and this box should be left blank.


编辑已有参考资料[编辑]


VisualEditor - Editing references 1.png
To edit an existing reference (citation), click on its number, in the text, and then click the "Reference" icon (bookmark) that appears near it, or the one in the "Insert" pulldown toolbar.

VisualEditor - Editing references 6.png
A dialog will open that includes a box where you can edit the text for that reference.

You can format that text in the same way you can on the main editing page. For example, you can add italics or links.


VisualEditor - Editing references 3.png
If the reference was created using a template, two things will happen when you click on the text of the reference: the text will be boxed, with a blue background, and a Transclusion/Template icon (puzzle piece) will appear.

To edit the template parameters that make up the reference, you must click on the puzzle piece icon.



VisualEditor - Editing references 5.png
After you click the Transclusion icon, you can edit each of the template's individual parameters. (For more details on doing this, see the Editing templates section, below.)

When you're done editing the template, click "Apply changes", and you'll go back to the main reference dialog box.


VisualEditor - Apply changes.png
If there is nothing more to edit, in the main reference dialog box, click again on "Apply changes" to return to the main editing page.

在新的地方添加已有的参考资料[编辑]


VisualEditor references more.png
A reference can be used in multiple places on a page, if it supports the text at each of those places.

To use (or reuse) an existing reference, place your cursor in the text where you want to add that reference. Then enter the "Insert" pulldown on the toolbar and click on the "Reference" icon (bookmark).

You'll now see the Reference dialog box. At the bottom left, click "Use an existing reference", which will get you to a list of all the existing references.


VisualEditor - Editing references 18.png
If there are many references, you can scroll through them to find the one you want. Or you can use the search bar to look for specific text (one or more words next to each other).

When you find, in the list, the reference you want to reuse, select it (click on it). Then click the "Insert reference" button (bottom right) to insert that reference into the text of the page you are editing, at the place you placed your cursor.

编辑模板[编辑]

为添加新目标到页面中,请把光标放在待插入的目标位置后点击工具栏“插入”菜单中的“模板”(如拼图样的图标)按钮,以添加模板。
VisualEditor reference toolbar transclusion.png

在对话框中,输入您想插入的模板的名称。这时您就会见到模板名字的列表出现,如果对勾标在您要添加的模板上,或者您点击任意一个您想要加入的模板,您可以点击“添加模板”。如果您使用了Monobook界面,这个列表就不会出现。改用默认皮肤Vector。
VisualEditor - Template editing 4.png

你也可以编辑页面已存在的模板,当选择到模板时,会显示为蓝色的块,并显示“模板”(如拼图样的图标)按钮,点击它,或者点击在工具栏的同样按钮。
VisualEditor - Template editing 1.png

如果您加入了新模板,每个参数都定了模板数据,会列出该模板的已有的参数。如果模板数据没有定义,对话框中就会有模板文档的链接。通过点击“添加参数”按钮插入其他参数。您可以编辑参数的值,或者删除它们——直接在对话框点击就能修改值。
VisualEditor - Template editing 3.png

对于复杂的、多个部分的转置,点击“显示选项”。您所选的模板、内容区块和参数的转置会列在左边。

为浏览您所加入的参数,如果您没看右边可以的参数列表,在对话框左边的点击模板名称。为了从列表加入特定参数,点击参数名(不要双击)。如果您没看到您所选的参数,您可以用搜索框去寻找,再点击参数名。

VisualEditor - Template editing 2b.png

完成后,点击“应用更改”以关闭对话框并返回到编辑页。
VisualEditor - Apply changes.png

子模板[编辑]

在一个模板嵌入其他模板的时候,这些子模板将会出现在显示它们的参数里面。可以在参数中编辑或删除。

新的子模板可通过后续添加章节的步骤加入。您需要参阅模板文档以确保子模板受到支持。

VisualEditor - Template editing 5.png

替换引用模板[编辑]


若模板必须替换引用,您必须输入subst:(包括冒号)于模板名之前。

自动补全功能不能与subst:使用;如果您需要自动补全,只有在您找到模板之后添加subst:

然后,点击绿色的“添加模板”按钮。

VisualEditor - Template editing 7.png

像平常一样插入参数并点击“应用更改”。
VisualEditor - Template editing 6.png

在应用可视化编辑器的初始阶段,替换引用模板不会在您退出对话框之后拓展到主页面。只有您在完成更改并保存页面之后替换引用才会生效;替换引用的效果将会在下一个人用可视化编辑器编辑的的时候见到。
VisualEditor - Template editing 8.png


编辑分类[编辑]


VE toolbar more settings.png
为编辑页面分类,点击工具栏上面的“更多设置”。

VisualEditor - More Settings.png
“更多设置”下拉菜单可访问“分类”按钮。

VisualEditor - Category editing 1.png
打开的对话框会列出本页面已有的分类,你可以编辑已有的或添加新的。

在“选项”中,您可以指定页面怎样列入分类,或在其中排序。


VisualEditor - Category editing 3.png
为添加新分类,在标有“添加分类”的输入框输入分类名。您会看到添加推荐分类的选项,即使分类不存在。

VisualEditor - Category editing 2.png
为删除分类,点击它,并在弹出的对话框中点击“删除”图标(垃圾桶)。

您还可以在这个对话框中指定在分类中排序的关键字。这个会替代默认的排序关键字。


VisualEditor - Apply changes.png
在编辑分类完成后点击“应用更改”(对话框右上角),您会返回到主编辑页面。

可视化编辑器不能做[编辑]

一些项目如隐藏的文本、图库、数学公式和乐谱没被可视化编辑器支持。在支持之前,如果您想更改或者添加这些项目,您需要直接编辑源代码(使用“编辑源代码”标签)。

可视化编辑器现在不能表格的格式,包括添加或删除行或列。然而,已有单元格的内容仍能编辑。

您不能从一个页面复制不丢失斜体、粗体、wiki链接或其他标记的内容粘贴到另一个页面。尤其是注脚和模板不能用可视化编辑器从一个页面负责粘贴到另一个页面。

您不能加入您的签名(用Flow提供)或者使用其他任何wiki代码。

快捷键[编辑]

快捷键可使编者快速排版而不用点击工具栏上面的图标。一般常用的快捷键和其他编辑软件用的快捷键也能在可视化编辑器用。完整的列表在这里,加入了鼠标和键盘操作的全部列表。更常用的快捷键如下所列。

PC快捷键 操作 符号 Mac快捷键 PC快捷键 操作 符号 Mac快捷键


Ctrl+B 粗体 VisualEditor - Icon - Bold-b.svg Cmd+B Ctrl+K 插入链接 VisualEditor - Icon - Link.svg Cmd+K


Ctrl+I 斜体 VisualEditor - Icon - Italic-i.svg Cmd+I Ctrl+X 剪切 Cmd+X


Ctrl+Z 撤销 VisualEditor - Icon - Arched-arrow-rtl.svg Cmd+Z Ctrl+C 复制 Cmd+C


Shift+Ctrl+Z 恢复 VisualEditor - Icon - Arched-arrow-ltr.svg Shift+ Cmd+Z Ctrl+V 粘贴 Cmd+V