Composer (軟體)

维基百科,自由的百科全书
跳到导航 跳到搜索
Composer
Logo-composer-transparent.png
開發者Nils Adermann
Jordi Boggiano
穩定版本
1.7.2[1]
(2018年8月16日 (2018-08-16)
源代码库 編輯維基數據鏈接
编程语言PHP
操作系统Cross-platform
类型软件包管理系统
许可协议MIT許可證
网站getcomposer.org

ComposerPHP软件包管理系统,它提供用于管理PHP软件和依赖库关系的标准格式。 它由Nils AdermannJordi Boggiano开发。 他们于2011年4月开始开发,并于2012年3月1日首次发布第一个版本。[2]Composer 的产生是由于受到了 Node.jsnpm 以及 Rubybundler 的启发。[3] 该项目的依赖关系解决算法最初是来自openSUSElibzypp包管理器。

使用语法[编辑]

命令[编辑]

Composer 提供了几个参数,包括[4]

  • require:向composer.json添加一个依赖库,并且安装它
  • install:从composer.json安装依赖库,通常在下载一个PHP项目的所有依赖时使用
  • update:根据composer.json中允许的版本范围更新依赖库
  • remove:删除一个依赖库,并将其从composer.json中移除

依赖库定义[编辑]

composer require monolog/monolog

以上命令会在composer.json中生成

{
    "require": {
        "monolog/monolog": "1.2.*"
    }
}

指定版本[编辑]

所安装依赖库的版本可以由以下几种运算符定义:[5]

运算符 作用 (放置在版本号前时) 示例
>= 允许高于此版本的依赖

以此类推,我们可以使用><<=

"php": ">=5.5.9" 包括 PHP 7
!= 排除一个版本的依赖
- 定义一个依赖的范围
|| 或运算符,寻找二者中存在的版本 "symfony/symfony": "2.8 ¦¦ 3.0" 将查找该依赖的2.8或3.0版本
* 通配符,允许一切符合要求的子版本 "symfony/symfony": "3.1.*" 包括 3.1.1 版本
~ 允许同级别的下一个版本 "doctrine/orm": "~2.5" 包括 2.6,但是不包括 2.4 或 3.0.
^ 类似于~,但是只允许向后兼容的版本

支持的框架[编辑]

註解[编辑]

  1. ^ 存档副本. [2017-03-19]. (原始内容存档于2017-03-15). 
  2. ^ Release 1.0.0-alpha1 · composer/composer. GitHub. [2020-08-06]. (原始内容存档于2019-03-27) (英语). 
  3. ^ Introduction - Composer. getcomposer.org. [2020-08-06]. (原始内容存档于2018-02-12). 
  4. ^ Command-line interface / Commands - Composer. getcomposer.org. [2020-08-06]. (原始内容存档于2020-08-04). 
  5. ^ Versions and constraints - Composer. getcomposer.org. [2020-08-06]. (原始内容存档于2020-09-14). 

外部連結[编辑]